¿Actualizo a Symfony 2.3?

Posted by victor on June 14th, 2013
symfony2-logoRecientemente se ha lanzado Symfony 2.3 y la pregunta que cualquier desarrollador se suele hacer es ¿Debo actualizar la versión?. La respuesta, en general, es SI, aunque cada uno conoce las peculiaridades de sus proyectos. Es muy recomendable actualizar a Symfony 2.3 porque se trata de una versión LTS y ello te garantiza actualizaciones durante los próximos 3 años. Las versiones LTS son ideales para proyectos de empresas donde las versiones con largos periodos de vida son muy bien acogidas porque permiten a los desarrolladores centrarse en su proyecto tomando como base un framework estable en el que no llegarán grandes novedades pero si que se mantendrá actualizado en cuanto a temas de seguridad. Un buen ejemplo de ello son las versiones LTS de Ubuntu que permiten a empresas montar servidores sin preocuparse, al menos por un tiempo, de si las novedades de versiones estándar se acomodarán bien a la situación de su negocio. Por supuesto, si creas nuevos proyecto, lo esperado es que partas de la versión 2.3 porque la anterior 2.2 tiene fecha de caducidad en Noviembre de este año. Versiones anteriores a la 2.2 han dejado de mantenerse y seguir utilizándolas implica que no estaremos protegidos frente a nuevos bug de seguridad. Para facilitar la información acerca del tiempo de vigencia de las versiones de Symfony, se ha creado una pequeña utilidad en la que se introduce la versión y se obtiene datos como la fecha de lanzamiento y la duración del mantenimiento.

Tipos de versiones Symfony

A modo de resumen, dejo las características de los distintos tipos de versión del framework:
  • Estándar: Una versión cada 6 meses con 8 meses de mantenimiento en bug normales y 14 meses de mantenimiento para bug de seguridad.
  • LTS: Una versión cada 24 meses con 36 meses de mantenimiento en bug normales y 48 meses de mantenimiento para bug de seguridad.
  Symfony: Actualizar 2.2 a 2.3. Symfony: Which version of Symfony should you use?

Comments

comments powered by Disqus