Actualizar PHP en Ubuntu 12.04

Posted by victor on July 3rd, 2013
php-logoLa versión 12.04 es una de las más utilizadas gracias a que es una LTS -versión de largo mantenimiento-. Los repositorios configurados por defecto siguen usando la rama de  5.3.x  de PHP que ha quedado obsoleta. Lo recomendado en este momento es usar, como mínimo, la rama 5.4 lo que significa que o bien compilamos la versión o actualizamos la lista de repositorios con nuevos orígenes que contienen los paquetes actualizados. Esta última opción es la que tomé ayer para actualizar el servidor de desarrollo. Como origen tomé el repositorio de Ondřej Surý, uno de los más recomendados: Añadimos el nuevo origen: sudo add-apt-repository ppa:ondrej/php5 Instalamos PHP 5.4: sudo apt-get install php5 Pude que tras la instalación obtentas algún mensaje del tipo "... Unable to load dynamic library ...". Los mensajes se deben a que intenta cargar algún módulo que no se encuentra en la ruta indicada por el php.ini. Lo recomendado es revisarlo y ver que otros ficheros .ini carga mediante phpinfo(). En mi caso, tuve que cambiar la ruta de xdebug.so.

Actualizar a PHP 5.5

La versión más reciente (es del 20 de Junio) es la 5.5.0. Para actualizar podemos seguir el tutorial de Brandon Savage: "Compiling PHP 5.5 from the scratch" si queremos compilarla o añadir un nuevo origen de Ondřej Surý para la esta versión: Añadimos el nuevo origen: sudo add-apt-repository ppa:ondrej/php5-experimental Instalamos: sudo apt-get install php5

Comments

comments powered by Disqus